Command Line
FAILURE: Build failed with an exception.

* What went wrong:
Could not determine java version from '10.0.1'.

Fix #1

Fix #2

  • Make sure you have also upgraded your build.gradle configuration
buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.3.3'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

Fix #3

Add the following under your build.gradle file

subprojects {
    afterEvaluate {project ->
        if (project.hasProperty("android")) {
            android {
                compileSdkVersion 25
                buildToolsVersion '25.0.0'
            }
        }
    }
}

Voila!